I reported this issue back in 9/6 on support.statamic.com and am still waiting for a reply. Since then, I have done more troubleshooting with the hosting provider (Media Temple) to make sure the directory permissions are set correctly. But I am still having the same caching issue:

Per your suggestion in this discussion thread: http://support.statamic.com/discussions/problems/3740-changes-not-a... I updated to the latest version (1.8.4) but the problem still persists.

Here is I am observing: 1. Changes I make to the homepage is simply not being applied. 2. Changes to areas other than the homepage get applied just fine. 3. The only way I can get the content update on the homepage to be applied is by going to the Settings page and set the Slug field to something random so the site style would break first when I load the homepage and then I go back to the Settings page and set the Slug field back to “settings” and then reload the page then the changes would be applied. (this seems to indicate that this is a caching issue)

What I have done in troubleshooting: 1. In config/settings.yaml I have already set cache expire to false: _http_cache_expires: false 2. In _config/bundles/htmlcaching/html_caching.yaml I have set "enable: false" 3. I have set folder permissions to 777 4. I have tested this multiple browsers and made sure I cleared the browser cache in all of them.

Any suggestions on what to do here?

Alex