I notice in the docs for Markitup it says "This is the default editor for your content field," however I am seeing a regular HTML rich text editor for the content field. This causes problems because when I save a markdown file through the control panel, it saves it back to disk as HTML.

How could I make sure the control panel displays the markitup editor for content field, and saves the file as markdown?

I should say, I have _content_type: markdown set inside settings.yaml.

Answered by Ross Barnes! Go to answer.