We've retired the forum in favor of GitHub Discussions.

New conversations can be started on GitHub. Existing conversations will remain for a while longer.

Head over to GitHub →

Upgrade Error: Couldn't install dependencies (v2.8.2 -> 2.8.3)

Peter Emil van den Berg January 23, 2018 by Peter Emil van den Berg

When upgrading Statamic I got this upgrade error:

Couldn't install dependencies.
The command "php composer.phar update erin-dalzell/mailchimp --prefer-dist --no-dev --optimize-autoloader" failed. Exit Code: 127(Command not found) Output: ================ Error Output: ================ sh: : command not found

I removed the folder Mailchip and the upgrade went fine afterwards. Then I placed the folder back in the add-ons folder and used php please update:addons, resulting in a successful Dependencies updated! message.

Is this the normal way when upgrading?

>>>>>>> Unanswered <<<<<<<
3 Replies
2 Followers