After I upgraded my statamic website to the latest version, I've been having permission related issues. When I try to access certain pages of the website, many of them return 500 errors or 200 “misconfiguration” errors. That happens only live (linux/apache), most frequently on admin pages and in recently added entries. It then takes one or a few reloads for the page to load properly. Also when I try to access /admin it returns a 404 page. I have to enter directly /admin/login.php, which sometimes returns a 500 error.

When I face those errors I conclude is something related with permissions, so I go to my FTP software (Transmit) and try to apply 777 to the folders (_content, _cache, _logs, assets). I apply 777 to these parent folders, but those errors keep coming up. Then I check and notice that certain enclosed files/folders inside those main folders are still 755. So I mark the option “Apply to enclosed” and click “Apply”, but it doesn't work and I get the following response: “Server said: 'SITE CHOWN' not understood”. If then I repeat this attempt too much, the website stops working (it stays in loading more, with blank screen). Maybe it's something with my server, but I've contacted the guys at the hosting company and they just answer that my application had “slow scripts” and “pool overflow”. Which doesn't help me - non expert - much.

As you probably can tell, I'm not an experienced web programmer, I'm more like a webdesigner. So I ask if anyone can help me in simple terms as to what problem exactly I'm facing and perhaps how to solve it.

Thanks :)

Below is the PHP error I get:

[07-Oct-2014 02:04:48] WARNING: [pool tecvitoria.com.br] child 13442, script '/home/tecvitoria/www/index.php' (request: "GET /index.php") executing too slow (2.117065 sec), logging
[07-Oct-2014 02:04:48]  [pool tecvitoria.com.br] pid 13442
script_filename = /home/tecvitoria/www/index.php
[0x00007ff8b10edc30] autoload_statamic() /home/tecvitoria/www/_app/core/functions.php:212
[0x00007fff5292ca20] autoload_statamic() unknown:0
[0x00007fff5292cd50] spl_autoload_call() unknown:0
[0x00007ff8b10ecc78] is_callable() /home/tecvitoria/www/_app/core/api/hook.php:67
[0x00007ff8b10e80d8] run() /home/tecvitoria/www/_app/routes.php:171
[0x00007fff5292d640] {closure}() unknown:0
[0x00007ff8b10e7da8] call_user_func_array() /home/tecvitoria/www/_app/vendor/Slim/Router.php:172
[0x00007ff8b10e7388] dispatch() /home/tecvitoria/www/_app/vendor/Slim/Slim.php:1290
[0x00007ff8b10e7098] call() /home/tecvitoria/www/_app/vendor/Slim/Middleware/Flash.php:86
[0x00007ff8b10e6aa0] call() /home/tecvitoria/www/_app/vendor/Slim/Middleware/MethodOverride.php:94
[0x00007ff8b10e5f40] call() /home/tecvitoria/www/_app/vendor/Zeuxisoo/Whoops/Provider/Slim/WhoopsMiddleware.php:71
[0x00007ff8b10e5a70] call() /home/tecvitoria/www/_app/vendor/Slim/Middleware/PrettyExceptions.php:67
[0x00007ff8b10e42b0] call() /home/tecvitoria/www/_app/vendor/Slim/Slim.php:1174
[0x00007ff8b10e4050] run() /home/tecvitoria/www/index.php:65

And below is my htaccess file:

# Turn on the Rewrite Engine
RewriteEngine On

# If you're running in a subfolder (like http://example.com/statamic),
# add that here. E.g. /statamic/
RewriteBase /

# Protect your system files from prying eyes
RewriteRule ^(_app) - [F,L]
RewriteRule ^(_config) - [F,L]
RewriteRule ^(_content) - [F,L]
RewriteRule ^(_logs) - [F,L]
RewriteRule ^(admin/themes/[^/]*/(?:layouts|templates)) - [F,L]
RewriteRule ^(.*)?\.yml$ - [F,L]
RewriteRule ^(.*)?\.yaml$ - [F,L]
RewriteRule ^(.*/)?\.git+ - [F,L]

# This will prevent all .html files from being accessed.
# You may want to remove this line if you want to serve
# static files outside of Statamic
# RewriteRule ^(.*)?\.html$ - [F,L]

# Remove trailing slashes from your URL
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)\/(\?.*)?$ $1$2 [R=301,L]

# Remove the index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php [QSA,L]

Ps.: I already tried to remove the slashes rules in the htacess file as suggested here, but it kept happening the same thing.

Answered by Juan Gonzalez! Go to answer.