I have been testing Statamic on my Windows 7 machine. I reported an issue in a previous thread and was given a nudge to find the answer. https://statamic.com/forum/3709-cp-problem-communicating-with-the-statamic-outpost "RequestException in CurlFactory.php line 187: cURL error 60: SSL certificate problem: unable to get local issuer certificate"

I thought I would share the resulting steps toward the solution which worked for me.

  • download the latest version of "cacert.pem" from https://curl.haxx.se/docs/caextract.html
  • rename the file to "cacert.pem.txt"
  • put the file in the WAMP ssl folder corresponding to your currently used php version(s). For me that was c:\wamp64\bin\php\php7.2.10\extras\ssl\cacert.pem.txt
  • add the following line under the "; php.ini Options ;" section of your php.ini file: curl.cainfo = "c:\wamp64\bin\php\php7.2.10\extras\ssl\cacert.pem.txt"

    (use the absolute path to wherever you put your cacert.pem.txt file)

  • "Restart All Services" in WAMP

That should do it!

Hope this helps.

If you don't know how to edit your php.ini file: - start WAMP - left click the green WAMP icon in your taskbar - hover on your PHP version until the flyout menu appears - click "php.ini" and it will open in your default text editor - add the line noted above - save the file.