Please add an API to your add-on so that if someone wants to use "extend" yours, they can just call the API instead of duplicating code (assuming the license allows, of course)