I just tried running Statamic in Docker using the steps in this repo and am getting an error that indicates that it only works on versions of Linux?

checking for libzip... not found

configure: error: Please reinstall the libzip distribution

ERROR: Service 'fpm' failed to build: The command '/bin/sh -c apt-get update && apt-get install -y libjpeg62-turbo-dev libpng-dev zlib1g-dev && rm -rf /var/lib/apt/lists/* && docker-php-ext-configure gd --with-jpeg-dir=/usr/include/ && docker-php-ext-install -j$(nproc) gd && docker-php-ext-install exif && docker-php-ext-install zip' returned a non-zero code: 1