Hi,

I uploaded my working local statamic project (2.11.15) to a webserver (directly to the webroot folder of the domain). I have an Apache running, PHP 7.3 and the server meets all requirements (I also tested it with the installer.php). I set the permission for the folders, subfolders and files. mod_rewrite is enabled on the server and I edited the settings file. Unfortunately I'm having the following Laravel error:

ReflectionException in Container.php line 741:
Class Statamic\Stache\Listeners\UpdateItem does not exist
in Container.php line 741
at ReflectionClass->__construct('Statamic\Stache\Listeners\UpdateItem') in Container.php line 741
at Container->build('Statamic\Stache\Listeners\UpdateItem', array()) in Container.php line 631
at Container->make('Statamic\Stache\Listeners\UpdateItem', array()) in Application.php line 674
at Application->make('Statamic\Stache\Listeners\UpdateItem') in Dispatcher.php line 149
at Dispatcher->resolveSubscriber('Statamic\Stache\Listeners\UpdateItem') in Dispatcher.php line 135
at Dispatcher->subscribe('Statamic\Stache\Listeners\UpdateItem') in EventServiceProvider.php line 39
at EventServiceProvider->boot(object(Dispatcher)) in EventServiceProvider.php line 35
at EventServiceProvider->boot(object(Dispatcher))
at call_user_func_array(array(object(EventServiceProvider), 'boot'), array(object(Dispatcher))) in Container.php line 507
at Container->call(array(object(EventServiceProvider), 'boot')) in Application.php line 734
at Application->bootProvider(object(EventServiceProvider)) in Application.php line 717
at Application->Illuminate\Foundation\{closure}(object(EventServiceProvider), '19')
at array_walk(array(object(EventServiceProvider), object(RoutingServiceProvider), object(AuthServiceProvider), 
object(ControllerServiceProvider), 
object(CookieServiceProvider), object(DatabaseServiceProvider), 
object(EncryptionServiceProvider), object(FilesystemServiceProvider), 
object(FormRequestServiceProvider), object(FoundationServiceProvider), 
object(PaginationServiceProvider), object(SessionServiceProvider), 
object(ValidationServiceProvider), object(ViewServiceProvider), 
object(AppServiceProvider), object(CollectionsServiceProvider), 
object(ServiceProvider), object(DataServiceProvider), 
object(FilesystemServiceProvider), object(EventServiceProvider), 
object(RouteServiceProvider), object(BladeServiceProvider), 
object(VideoEmbedServiceProvider), object(AddonServiceProvider), 
object(EmailServiceProvider), object(ValidationServiceProvider), 
object(ServiceProvider), object(CacheServiceProvider)), object(Closure)) in Application.php line 718
at Application->boot() in BootProviders.php line 17
at BootProviders->bootstrap(object(Application)) in Application.php line 203
at Application->bootstrapWith(array('Illuminate\Foundation\Bootstrap\DetectEnvironment', 
'Illuminate\Foundation\Bootstrap\LoadConfiguration', 
'Statamic\Bootstrap\UpdateConfiguration', 
'Illuminate\Foundation\Bootstrap\ConfigureLogging', 
'Illuminate\Foundation\Bootstrap\HandleExceptions', 
'Illuminate\Foundation\Bootstrap\RegisterFacades', 
'Illuminate\Foundation\Bootstrap\RegisterProviders', 
'Illuminate\Foundation\Bootstrap\BootProviders')) in Kernel.php line 222
at Kernel->bootstrap() in Kernel.php line 117
at Kernel->sendRequestThroughRouter(object(Request)) in Kernel.php line 87
at Kernel->handle(object(Request)) in index.php line 167

https://new.fkpscorpio.pl/

I cleared the cache manually (local/storage/framework/cache). I only use a few addons and didn't changed any code or so. On my localhost everything works fine. I don't have any idea what else to do, but it seems a little bit server related? I also uploaded a fresh/clean statamic project to another account/domain at the same provider and have similar problems (Fatal error: Uncaught ReflectionException: Class log does not exist in /www/htdocs/w012a7af/blynx.at/statamic/vendor/laravel/framework/src/Illuminate/Container/Container.php:741 Stack trace: #0)

I already sent the problem a week ago to the support over the support form (I bought a license), but got so far no response.

Any suggestions what I could try?

Thanks! Raffael

Answered by Raffael H! Go to answer.