It would be nice to be able to filter by Addon requirement; i.e. on what verion can the addon run. For now (and for a while to come) there are multiple versions of Statamic that can be userd (or are in use). It would be nice if you can filter only addons for Statamic v3 for example.