Can't Update

Getting this message.

Couldn't install dependencies. The command "php composer.phar update lesaff/useragent --prefer-dist --no-dev --optimize-autoloader" failed. Exit Code: 2(Misuse of shell builtins) Output: ================ Error Output: ================ Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an installable set of packages. Problem 1 - Installation request for doctrine/instantiator (locked at 1.2.0) -> satisfiable by doctrine/instantiator[1.2.0]. - doctrine/instantiator 1.2.0 requires php ^7.1 -> your PHP version (7.0.33) does not satisfy that requirement. Problem 2 - Installation request for myclabs/deep-copy (locked at 1.9.1) -> satisfiable by myclabs/deep-copy[1.9.1]. - myclabs/deep-copy 1.9.1 requires php ^7.1 -> your PHP version (7.0.33) does not satisfy that requirement. Problem 3 - doctrine/inflector v1.3.0 requires php ^7.1 -> your PHP version (7.0.33) does not satisfy that requirement. - doctrine/inflector v1.3.0 requires php ^7.1 -> your PHP version (7.0.33) does not satisfy that requirement. - doctrine/inflector v1.3.0 requires php ^7.1 -> your PHP version (7.0.33) does not satisfy that requirement. - Installation request for doctrine/inflector (locked at v1.3.0) -> satisfiable by doctrine/inflector[v1.3.0]. Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.

>>>>>>> Unanswered <<<<<<<
3 Replies
2 Followers