We've retired the forum in favor of GitHub Discussions.

New conversations can be started on GitHub. Existing conversations will remain for a while longer.

Head over to GitHub →

Struggling on first install

Forrest Doddington October 19, 2020 by Forrest Doddington

I am a newbie to Statamic, but hoping to learn more and possibly move some sites from Drupal to Statamic. However, I'm struggling to have success with a first install.

I've worked with my hosting provider and gotten the current version of Composer loaded and the PHP memory limit increased. With those in place, the Terminal command "composer create-project --prefer-dist statamic/statamic site_firsttry" completed successfully (no more error related to insufficient PHP memory).

I created a sub-domain (e.g. http://firsttry.myserver.com) and pointed it to the "site_firsttry" folder on my web server.

I edited the .env to update this line: APP_URL=http://firsttry.myserver.com

When I go to http://firsttry.myserver.com with my web browser, I receive this error message:

    Forbidden
    You don't have permission to access this resource.
    Additionally, a 403 Forbidden error was encountered while trying to 
    use an ErrorDocument to handle the request.

And when I go to http://firsttry.myserver.com/cp with my web browser, I receive this error message:

    Not Found
    The requested URL was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to 
    use an ErrorDocument to handle the request.

Help please!! I'm stumped. What do I need to do to get a Statamic base/empty install working?

Answered by Erin Dalzell!
>>>>>>> Answered <<<<<<<
5 Replies
2 Followers