New: Learn Statamic on Laracasts!

We've retired the forum in favor of GitHub Discussions.

New conversations can be started on GitHub. Existing conversations will remain for a while longer.

Head over to GitHub →

Breadcrumbs don't show up properly

Konrad April 14, 2021 by Konrad

Breadcrumbs work fine in my dev environment but only show the top level page in the staging/prod environment - any idea how to debug this?

I also tried to build the prod docker container I use to deploy the site in my staging environment locally but even then the breadcrumbs worked on my dev machine (through the prod container running locally). This makes me think this could be some kind of cache warming issue?

Edit: I've switched the redis cache to filesystem cache and it looks like the breadcrumb is already wrong in the cached file in storage/framework/cache/.... Not sure if that's relevant.

Breadcrumbs in my dev environment

Breadcrumbs in the staging environment

Answered by Konrad!
>>>>>>> Answered <<<<<<<
5 Replies